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Release Notes

1.  New functionality in this release

❍     MIMIC Virtual Lab CCNA v5.20

Based on MIMIC Simulator 10.20 

2.  New functionality in previous releases

1.  MIMIC Virtual Lab CCNA v5.10

Based on MIMIC Simulator 10.10 

2.  MIMIC Virtual Lab CCNA v4.40

MIMIC Virtual Lab CCNA Plus v4.40

MIMIC Virtual Lab Enterprise v5.40

Based on MIMIC Simulator 9.40 

3.  MIMIC Virtual Lab CCNA v4.30

MIMIC Virtual Lab CCNA Plus v4.30

MIMIC Virtual Lab Enterprise v5.30

Based on MIMIC Simulator 9.30 

4.  MIMIC Virtual Lab CCNA Plus v4.20

http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/


MIMIC Virtual Lab Enterprise v5.20

Based on MIMIC Simulator 9.20 

5.  MIMIC Virtual Lab CCNA v4.10

MIMIC Virtual Lab BSCI v5.10

Based on MIMIC Simulator 9.10 

6.  MIMIC Virtual Lab CCNA v3.42

Tech2000 Virtual Lab CCNA v3.41

Based on new ICND2 lab guide. 

Based on MIMIC Simulator 8.41 

7.  MIMIC Virtual Lab CCNA Plus v2.31

MIMIC Virtual Lab Enterprise v4.31

Based on MIMIC Simulator 8.31 

8.  MIMIC Virtual Lab CCNA v2.30

MIMIC Virtual Lab BSCI v4.30

Based on MIMIC Simulator 8.30 

9.  MIMIC Virtual Lab CCNA v2.20

MIMIC Virtual Lab CCNA Plus v2.20

MIMIC Virtual Lab BSCI v4.20

MIMIC Virtual Lab Enterprise v4.20

Based on MIMIC Simulator 8.20 

http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/


10.  MIMIC Virtual Lab CCNA v2.00

MIMIC Virtual Lab CCNA Plus v2.00

MIMIC Virtual Lab BSCI v4.00

MIMIC Virtual Lab Enterprise v4.00

Based on MIMIC Simulator 8.00 

11.  MIMIC Virtual Lab CCNA v1.60

MIMIC Virtual Lab BSCI v3.30

MIMIC Virtual Lab Enterprise v3.30

OEM Versions of MIMIC Virtual Lab

Based on MIMIC Simulator 7.31 

add/remove links between devices 

12.  MIMIC Virtual Lab CCNA v1.50

MIMIC Virtual Lab Cisco v4.20

MIMIC Virtual Lab BSCI v3.20

MIMIC Virtual Lab Enterprise v3.20

OEM Versions of MIMIC Virtual Lab

Based on MIMIC Simulator 7.20 

disconnect/reconnect links between devices 

SNMPv1 configuration via "snmp-server" command 

dynamic command aliases via "alias" command 

13.  MIMIC Virtual Lab CCNA v1.11

http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/


MIMIC Virtual Lab Cisco v4.10

MIMIC Virtual Lab BSCI v3.10

MIMIC Virtual Lab Enterprise v3.10

Based on MIMIC Simulator 7.00 

telnet client simulation via "telnet" command 

remote logging through SYSLOG via "logging" command 

Cisco TRAP generation via "snmp-server" command 

Console vs. telnet simulation 

14.  MIMIC Virtual Lab Cisco v3.10

MIMIC Virtual Lab BSCI v2.10

MIMIC Virtual Lab Enterprise v2.10

Based on MIMIC Simulator 6.30 

Downloadable MPLS lab. 

15.  MIMIC Virtual Lab Cisco v3.00

MIMIC Virtual Lab BSCI v2.00

MIMIC Virtual Lab Enterprise v2.00

Based on MIMIC Simulator 6.20 

Support the Linux and Solaris platforms. 

Allow to change the network address for the lab. 

16.  MIMIC Virtual Lab Cisco v2.10

MIMIC Virtual Lab BSCI v1.10

http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/


MIMIC Virtual Lab Enterprise v1.00

Based on MIMIC Simulator 6.10 

17.  Cisco Lab I v2.00

Based on MIMIC Simulator 6.00 

Exercises to dynamically alter the lab. 

MIB Browser. 

Load multiple lab configurations. 

Update labs over the Internet. 

18.  Cisco Lab I v1.10

Based on MIMIC Simulator 5.99 

19.  Cisco Lab I v1.00

First virtual lab containing 4 routers, 2 switches, 5 end systems 

Based on MIMIC Simulator 5.46 
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Windows Installation Instructions

1.  Table of Contents
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❍     Crashes 

❍     Known Problems 

2.  Overview

MIMIC Virtual Lab runs on 

❍     Windows NT 4.0 Service Pack 4 or newer 

❍     Windows 2000 

❍     Windows XP 

❍     Windows Server 2003 

❍     Windows Vista Business Edition 

with at least Java Runtime Environment (JRE) 1.4. 

Notice that although MIMIC Simulator supports the other versions of Windows (95, 98, Me, NT SP 3), the limitations are 

too severe to run MIMIC Virtual Lab on them. 

The following are some of the most common problems encountered on Windows, and their fixes: 

3.  Account Privileges

On Windows NT, 2000, XP or Server 2003, you need to install MIMIC from a user account with Administrator privileges, 

since the install script needs write access to restricted parts of the Registry. 

http://java.sun.com/j2se


You also need to run MIMIC from an account with Administrator rights, since it uses special privileges to add additional IP 

addresses to the machine you are running on. 

We recommend establishing a separate user account with Administrator privileges for running MIMIC. This strictly controls 

who has access to this functionality. 

4.  Firewalls

Due to pervasive security attacks against Windows systems connected to the Internet, it has become common to run a 

software firewall on recent versions of Windows. 

MIMIC will coexist with a software firewall, provided that the firewall is configured to recognize MIMIC as a program 

allowed to access the network. MIMIC will, due to its very nature of simulating networked components, open network 

sockets and communicate with external applications (eg. network management applications, telnet clients, etc). 

There are certain components of MIMIC that will access the Internet (eg. specific web sites to determine software updates, 

etc). 

5.  Disk Space

MIMIC creates a lot of small files for its simulations. This is handled efficiently on modern filesystems, such as NTFS and 

Unix file systems, On the other hand, the FAT (or FAT16) filesystem on all Windows 95 (and some Windows 98 or NT) 

systems is notoriously inefficient, and you will use 10 to 100 times more disk space on a FAT file system. (The FAT32 file 

system on Windows 98 is also inefficient, but it is acceptable.) To find out what file system you have installed on your 

Windows system, select the Properties dialog on your partition from the Windows Explorer. 

6.  Assigning IP Addresses

MIMIC requires at least one operational network interface card (NIC). On Windows NT, 2000, XP or Server 2003, as on the 

Unix platforms, MIMIC dynamically assigns IP addresses when starting each agent instance. 

7.  Duplicate IP Address

If Windows detects that an IP address on one of its Network Interface Cards (NICs) conflicts with another system 

(duplicate IP address), then it tries to resolve this problem by shutting down the NIC and displays a message such as: 

The System has detected an IP address conflict with another system on the

network.  The local interface has been disabled.  More details are

available in the system event log. Consult your network administrator to

resolve the conflict.

You must not have duplicate IP addresses on a connected network, neither with MIMIC or otherwise. 

NOTE: on Windows 2000, XP or Server 2003, the agent will not start and will print an error message in the Log. 



8.  Media Sense on Windows 2000 and newer

Newer versions of Windows (Windows 2000 onwards) have a TCP/IP feature whereby it can sense if a NIC is actually 

connected to the network. By default, a NIC is disabled if it is not found to be on the network, which prevents agents from 

starting in MIMIC. There is a way to disable this behaviour so that you can work on standalone Windows machines. 

Attached is the Microsoft KB article on this topic... Please remember to make a copy of your registry before making any 

changes just to be on the safe side. 

How to Disable Media Sense for TCP/IP in Windows 2000

----------------------------------------------------------------------------

----

The information in this article applies to:

  a.. Microsoft Windows 2000 Advanced Server

  b.. Microsoft Windows 2000 Datacenter Server

  c.. Microsoft Windows 2000 Professional

  d.. Microsoft Windows 2000 Server

----------------------------------------------------------------------------

----

SUMMARY

Windows 2000 contains the "Media Sensing" feature. You may use this feature

on a Windows 2000-based computer using Transmission Control

Protocol/Internet Protocol (TCP/IP) to detect whether or not your network

media is in a "link state". A "link state" is defined as the physical media

connecting or inserting itself on the network. For example, assuming a 10bt

or 100bt physical media, Ethernet network adapters and hubs typically have a

"link" light to indicate the current connection status. This is the same

condition in which Windows 2000 can detect a link. Whenever Windows 2000

detects a "down" state on the media, it removes the bound protocols from

that adapter until it is detected as "up" again. There may be situations

where you may not want your network adapter to detect this state, and you

can configure this by editing the registry.

NOTE: 10b2 or coaxial (RG-58) Ethernet cable is not a connection-based

media. Because of this, Windows 2000 does not attempt to detect a "connect"

state if this type of cabling is used.

http://support.microsoft.com/


MORE INFORMATION

WARNING: Using Registry Editor incorrectly can cause serious problems that

may require you to reinstall your operating system. Microsoft cannot

guarantee that problems resulting from the incorrect use of Registry Editor

can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys and

Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete

Information in the Registry" and "Edit Registry Data" Help topics in

Regedt32.exe. Note that you should back up the registry before you edit it.

If you are running Windows NT or Windows 2000, you should also update your

Emergency Repair Disk (ERD).

To prevent your network adapter from detecting the link state:

NOTE: NetBEUI and IPX do not recognize Media Sense.

  1.. Use Registry Editor (Regedt32.exe) to view the following key in the

registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

  Add the following registry value:

    Value Name: DisableDHCPMediaSense

    Data Type: REG_DWORD -Boolean

    Value Data Range: 0, 1 (False, True) Default: 0 (False)

  Description: This parameter controls DHCP Media Sense behavior. If you set

this value data to 1, DHCP, and even non-DHCP, clients ignore Media Sense

events from the interface. By default, Media Sense events trigger the DHCP

client to take an action, such as attempting to obtain a lease (when a

connect event occurs), or invalidating the interface and routes (when a

disconnect event occurs).

  2.. Restart your computer.

NOTE: There are some side effects of disabling the "Media Sensing" feature.

For example, if you have a machine with two network adapters, and you have



the "Media Sensing" feature enabled, if one network adapter does not work,

it is unbound, and associated routes are removed so that all traffic goes

through the other network adapter (assuming a default gateway is there).

Also, if you are a roaming (portable) user, the "Media Sensing" feature is

what provides the ability to connect to any network and have everything

work, without restarting, release and renewing, and so on. After disabling

Media Sense and restarting, Windows 2000 still shows the "Network

Disconnected" icon on the TaskBar and the 'ipconfig' command still shows a

"Media State .....: Cable Disconnected" message when the cable is

disconnected. However, the Network Interface is bound to TCP/IP and you can

verify this by looking at the route table --you can use the "route print"

command-- which shows the interface IP address (you are also able to ping

the IP address assigned to the NIC).

*END*

9.  Windows Vista

1.  User Account Control

Windows Vista has the new User Account Control feature, which impacts the running of MIMIC. For details, consult this 

Analysis of the Windows Vista Security Model from Symantec. In order to enable to run MIMIC on Vista, you have 2 

options: 

■     Disable User Account Control 

This turns UAC off globally. NOTE: do this only if you are aware of the implications of this action. 

■     Open User Accounts via Start->Control Panel->User Accounts->User Accounts. 

■     Click on Turn User Account Control on or off 

■     Clear the checkbox for Use User Account Control (UAC) to help protect your computer. 

■     Click Ok 

■     A dialog will popup prompting you to Restart Now or Restart Later. Choose appropriately. User Account Control will be disabled 

once the system reboots. 

■     Run MIMIC with User Account Control enabled 

This involves changing the access control level of the MIMIC programs. 

■     Change the privilege level of MIMIC Virtual Lab application in the MIMIC Start Program group using the following steps: 

■     Click Start->All Programs->MIMIC Virtual Lab ... x.xx 

■     Move the cursor to the MIMIC Virtual Lab ... entry 

■     Right click and select Properties. 

■     In the Compatibility tab, check Run this program as an administrator 

■     Once this is done, MIMIC Virtual Lab can be started as above or by running the VLABx.bat script in the bin folder of the MIMIC 

http://www.symantec.com/avcenter/reference/Windows_Vista_Security_Model_Analysis.pdf


installation. 

■     If MimicD.exe will be run directly, set the privilege level of it using the following steps: 

■     In Windows Explorer, select it. 

■     Right click and select Properties. 

■     In the Compatibility tab, check Run this program as an administrator 

2.  Duplicate Address Detection

On Windows Vista, the new TCP/IP stack tries to do "duplicate address detection" by default. This prevents MIMIC from 

starting agents, because IP aliasing is delayed, and even with a workaround in our software would unacceptably slow down 

the starting of agents. To correctly workaround the problem, you need to disable "duplicate address detection" for the 

network interface using the Windows netsh utility: 

netsh interface ipv4 set interface "name or index" dadtransmits=0 

The interface name and index info can be obtained by 

netsh interface ipv4 show interfaces 

For example: 

H:\>netsh interface ipv4 show interfaces

Idx  Met   MTU   State        Name

---  ---  -----  -----------  -------------------

  1   50 4294967295  connected    Loopback Pseudo-Interface 1

  7   20   1500  connected    Local Area Connection

H:\>netsh interface ipv4 set interface "7" dadtransmits=0

3.  Vista Power Management

The default power options will put the Windows Vista system to sleep after 1 hour of inactivity. To disable this, perform the 

following: 

Open Power Options using Control Panel->System and Maintenance->Power Options. 

Change Preferred Plan from Balanced to High Performance. 

Verify by clicking on Change Plan Settings for High Performance. Ensure that Put the computer to sleep setting is 

Never. 

4.  Program Compatibility Assistant

After the install is completed or aborted, the Program Compatibility Assistant may prompt with the message 

This program might not have installed correctly.



Please select This program installed correctly if the install completed. Else, select Cancel. 

10.  Crashes

Prior to Windows Vista, crashes can be analysed post-mortem using the Dr. Watson Tool crash dumps. This requires that 

Dr. Watson be enabled to handle any application exceptions on the system. 

To install Dr. Watson as the default exception handler : 

❍     Click Start->Run. 

❍     Type drwtsn32 -i 

❍     Click Ok. 

A subsequent crash should popup the Dr. Watson dialog. Search for the following files in the Windows directory (this 

location can be changed using the Dr. Watson GUI) : drwtsn32.log and user.dmp . Send these to Gambit Technical 

Support (support@gambitcomm.com).

On Windows Vista, by default the Problem Reports and Solutions feature handles program crashes. Crash information, 

including minidumps when available, is automatically sent to Microsoft. 

You can check if a MIMIC program crashed and if minidumps are available. Please use the following steps to extract any 

available MIMIC program crash data and forward it to Gambit Technical Support ( support@gambitcomm.com). 

❍     Go to Problem Reports and Solutions using Control Panel->System and Maintenance->Problem Reports and Solutions 

❍     Click on View problem history 

❍     Find MIMIC programs in the list 

❍     Double click on an entry to view the problem details 

❍     If there is a Files that help describe the problem section, click on the View a temporary copy of these files link 

below that section 

❍     The files will be extracted into a temporary directory and an Explorer window will be opened to view them 

❍     Forward these to Gambit Technical Support 

If the Problem Reports and Solutions settings are changed to check with the user before sending the crash 

information to Microsoft, Windows Vista will prompt the user when a program crash occurs. If you choose Close the 

program, no additional details are generated. If you choose Check online for a solution and close the program, 

crash data may be saved. 

Microsoft's Debug Diagnostic Tool version 1.1 onwards may be used on Windows Vista to handle program crashes. If this is 

installed, please use the following steps to generate crash data. 

❍     Open Debug Diagnostic Tool 

❍     Click on the Rules tab 

❍     Click on Add Rule button 

❍     In the Select Rule Type dialog, choose Crash and click on Next 

http://support.microsoft.com/kb/308538
mailto:support@gambitcomm.com
mailto:support@gambitcomm.com
http://support.microsoft.com/kb/931370


❍     In the Select Target Type dialog, choose A specific program and click on Next 

❍     In the Select Target dialog, browse the process list, select MimicD.exe and click on Next 

❍     In the Advanced Configurations (Optional) dialog, change the number of userdumps as needed and click on Next 

❍     In the Select Dump Location and Rule Name (Optional) dialog, change the path and name as needed and click on Next 

❍     In the Rule Completed dialog, choose Activate the rule now and click on Finish 

When a crash occurs, the Rules tab in Debug Diagnostic Tool will show the userdump count. Forward the available files 

from the configured dump location to Gambit Technical Support. 

11.  Known Problems

We are constantly working to remove limitations, but currently we know of the following: 

❍     MIMIC Virtual Lab relies on the native telnet client program on the platform it runs on to connect to the IOS 

simulations. On Windows NT, there are bugs in the telnet client that prevent interrupting commands such as ping 

with CTL-Shift-6. This works fine on later Windows versions and all Unix versions. 

On Windows Vista, the telnet client is not enabled by default. You need to enable it with Control Panel->Programs-

>Programs and Features-> Turn Windows features on or off. 

On 64-bit versions of Windows, the telnet client is not launched correctly. The workaround for this problem is to copy 

the Windows telnet executable from c:\windows\system32\telnet.exe to the bin/ folder of the MIMIC Virtual Lab 

install area. 

❍     On Windows NT, if the host is using DHCP to obtain its address, no agent instance can use that same address to 

export a MIB. The problem is that on stopping the agent this address is deleted which shuts off the TCP/IP services 

(ftp/telnet/internet). To restore working you either need to REBOOT or start the agent on the DHCP assigned address 

again (keep it running). 

❍     On Windows, certain network interface cards have limitations supporting multiple IP addresses. In particular, some 

adapters and/or drivers from 3com have been giving us trouble (eg. 3C905-TX or 3Com 3C90x Ethernet Adapter). 

The symptom is that a small number of agent instances can be started and polled correctly, but connectivity is lost to 

the box when starting more. 

❍     On Windows, certain software is incompatible with MIMIC. In particular, if Novell Client is running, your machine may 

hang after starting and stopping a small number of agents (the System task will use 99+% of CPU). Just unchecking 

the box in Local Area Connection Properties is not sufficient - you have to uninstall it. 

This problem is unrelated to MIMIC. Any test program (eg. ifdiag shipped with MIMIC) which uses the Windows API 

to register/unregister network addresses will reproduce the problem. 

❍     MIMIC will not run inside virtual machine software such as VMWare. 

In case of difficulties, please contact Gambit Technical Support (support@gambitcomm.com).

Obviously, Windows is a trademark of Microsoft. All other product and brand names are trademarks or 
registered trademarks of their respective holders. 
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Quick Start Guide

1.  Preface

This guide is a quick overview to using MIMIC Virtual Lab. It assumes that you are familiar with networking and network management concepts, 

particularly Simple Network Management Protocol (SNMP), Management Information Base (MIB), and telnet.

Organization

Using MIMIC Virtual Lab is recommended for use with an installed and running MIMIC to demonstrate the overall functionality of the product. 

Troubleshooting guides you through solving problems with MIMIC Virtual Lab. 

Important Concepts contains useful introductory definitions. 

Typography Conventions

Normal Text

Typewriter Computer output; names of functions and data types

Typewriter Interface components; menus, buttons and entry fields

Italics Values you can input; variable names, numbers, strings

Bold Normal What you have to type correctly, for example, filenames, Unix commands, function names, command-line entries

2.  Table of Contents

❍     Chapter 1: Overview

❍     Chapter 2: Using MIMIC Virtual Lab

■     Starting the lab

■     Using the GUI

■     Shortcuts

■     Accessing a device

■     Running an exercise

❍     Chapter 3: Troubleshooting

■     Online Help

■     Known Problems

■     Inspect the Log

■     Common Errors

■     Common Questions

■     Crashes

❍     Chapter 4: Background

■     Important Concepts

■     What Is a Device Instance?



■     What Is a Simulation?

■     What Is an Agent Instance?

■     What Is The Lab?

■     References for Further Reading

3.  Chapter 1: Overview

MIMIC Virtual Lab is simulation software that creates a user-friendly virtual lab environment for training purposes. It is part of the MIMIC suite of 

network simulation tools: 

The MIMIC SNMP Agent Simulator lets you simulate up to 10,000 SNMP-manageable devices on one Intel-based PC or Sun Sparc. Your network 

management application can send SNMP (v1, v2, v2c, v3) requests to the simulated agent, which can return SNMP responses or traps. Any SNMP-

based device is supported. You can run a variety of device configurations and customizable them at runtime. Because MIMIC responds to SNMP queries 

on any of its configured IP addresses, it looks to the application as though it were communicating to actual devices. 

The MIMIC Cable Modem Simulator extends the MIMIC SNMP Agent Simulator with the protocols necessary for simulating cable modems from an 

Operations Support System (OSS) perspective. The additional protocols are DHCP, TFTP, TOD and MGCP. 

The MIMIC IOS Simulator adds the capability to respond to Cisco IOS commands over Telnet. It gives Network Engineers an ability to practice for 

certifications instead of just reading from the instructions. 

There are 2 types of MIMIC Virtual Labs: 

❍     "Networked" labs, which allow remote access to the lab, either via telnet or SNMP. One such lab is MIMIC Virtual Lab CCNA Plus. 

❍     "Lite" labs, which do not allow remote access to the lab. The only way to access the devices in the lab is through the Device->Console or Device->Telnet 

menu items in the Virtual Lab user interface. One such lab is MIMIC Virtual Lab CCNA. 

Since this documentation covers both product lines, it may talk about remote functionality that does not apply to the "Lite" product you have installed. 

4.  Chapter 2: Using MIMIC Virtual Lab
Chapter Contents

❍     Starting the lab

❍     Using the GUI

❍     Shortcuts

❍     Accessing a device

❍     Running an exercise

Starting the lab

To start the MIMIC Virtual Lab on Microsoft Windows, invoke MIMIC Virtual Lab in the MIMIC Program Group (on Windows) or from the command 

line, which brings up the main front panel. 

http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/
http://www.gambitcomm.com/site/products/index_ccna.shtml
http://www.gambitcomm.com/site/products/index_ccna.shtml


 

Figure - MIMIC Virtual Lab Front Panel 

When you start the lab, the background MIMIC Simulator daemon will be invoked automatically if it is not already running. Each device agent in the lab 

is shown with an icon in the front panel, and color coded with red when it is stopped, and green when it is running. Initially the lab will be stopped, 

which is the same as if the real devices were not powered up. You need to start the lab with Lab->Start to access the devices. 

Using the GUI

Although the various labs may have slight look-and-feel differences, the MIMIC Virtual Lab GUI always contains the following components (from the 

top): 

❍     the title bar;

❍     the menu bar;

❍     the speed bar;

❍     the main canvas; and

❍     the status bar;



 

Figure - MIMIC Virtual Lab components 

In general, if you want to control a device, you select its device icons in the main canvas and perform actions with the Device menu items or speed bar 

buttons. The sections below introduce some of the tasks you can accomplish.

Shortcuts

Besides the ALT+letter keyboard shortcuts for menu entries, Virtual Lab also accepts the Tab key as a shortcut to the most common actions, which 

are shown in the speedbar below the top menu bar.

In addition, you can right-click on a device icon to select the device, and pop up a copy of the Device menu. In this tutorial, we will continue to use the 

menu entries for clarity. We suggest you use them until you get familiar, then start using the shortcuts. 

Accessing a device

Once a device is started, you can access it just like a real device, for example with a telnet client through Device->Console..., Device->Telnet... or any 

SNMP application (if you are running a "networked" lab). You can log into the devices with username lab and password lab123. The Device->Info... 

command will give you more information about the device, including IOS login, other passwords and SNMP community strings. 



The list of supported commands is in Appendix A. 

You can look at the device MIB with Device->MIB. 

 

Figure - Device MIB Dialog 

Running an exercise

As such, the lab is fairly static. You can now run exercises which change the lab in desired ways. Use Lab->Exercise to invoke the Lab Exercise dialog. 



 

Figure - Lab Exercise Dialog 

To run an exercise, select if from the Eligible list. If an exercise is listed under Ineligible you need to select the correct device to run it on. You can 

expand each exercise node with the + icon to reveal more informational nodes. Once you have selected an eligible exercise, click Apply to start it. Once 

activated, the exercise will appear under the Active node, and cycle through each step, prompting you to click Apply to continue at your own pace. 

We highly recommend to run at least the Tutorial: Basic IOS command line interface exercise once. It will give you brief introduction to how 

things work in the MIMIC Virtual Lab. 

5.  Chapter 3: Troubleshooting
Chapter Contents

❍     Online Help

❍     Known Problems

❍     Inspect the Log

❍     Common Errors

❍     Common Questions

❍     Crashes

This chapter lists the recommended troubleshooting procedures for quickest resolution of your problem. 

Online Help

All MIMIC Virtual Lab dialogs have a context-sensitive online help section, which you can invoke with the Help button. The complete online 

documentation is accessible with Help->Contents. 

Known Problems

Each of the supported platforms has known problems. Check there first to see if yours is one of them: 



❍     Windows 

Inspect the Log

MIMIC logs all abnormal events in a log viewable with the Lab->Troubleshoot menu item. In case anything goes wrong, inspect it first. 

Common Errors

Common errors in the log are detailed in Appendix C - Common Error Messages. Consult this section for details on your particular error. 

Common Questions

Common questions and their answers are detailed in Appendix D - Frequently Asked Questions. 

Crashes

MIMIC, as any other complex software, occasionally terminates abnormally (crashes). In order to help us diagnose and fix the problem, we will request 

you to provide some additional information about the problem such as 

❍     how did the crash occur? 

❍     what simulation was running? 

❍     how long had MIMIC been running? 

❍     can you reproduce the crash? 

In addition, we will request you to enable dumping of process memory on the crash. Details for Windows are in the Windows Installation sections. 

6.  Chapter 4: Background
Chapter Contents

❍     Important Concepts

■     What Is a Device Instance?

■     What Is a Simulation?

■     What Is an Agent Instance?

■     What Is The Lab?

■     References for Further Reading

Important Concepts

What Is a Device Instance?

In MIMIC terms, a device is a real-world entity on a network managed primarily via the Simple Network Management Protocol (SNMP) or telnet-based 

command-line interfaces such as Cisco IOS. The command-line interface is accessible with any telnet client. To be manageable via SNMP, the device 

exports a Management Information Base (MIB) with embedded software called an SNMP agent. The MIB is usually composed of a collection of standard 

and enterprise-specific MIB fragments, for example, MIB-2, IF-MIB, and SNMP-REPEATER-MIB, which we just call MIBs. Each MIB is defined in a syntax 

called "Structure of Management Information" (SMI). 

An SNMP-capable network management application interacts with one or more SNMP agents by manipulating MIB objects.



Figure - Network Management Topology 

You use MIMIC to simulate one or more instances of a device from the network management perspective, ie. you simulate the SNMP agent or telnet 

server. There are many different classes of devices, from data communications equipment to end systems, from tele-communications equipment to 

databases. 

What Is a Simulation?

A protocol simulation is the act of allowing protocol interaction with standard applications just as with a real-world device, but without the actual 

physical device. For SNMP that means exporting MIB object instances and values, generating TRAPs. For command-line interfaces that means exporting 

a command set such as Cisco IOS via telnet. The network management applications interact with the simulations within MIMIC just as it would with 

real-world devices.

Figure - Simulations with MIMIC 

What Is an Agent Instance? 

An agent instance is a simulation of a device instance within MIMIC. There can be more than one agent instance of the same device, such as 2 routers 

or computers of a particular type. The main thing to realize is that each agent instance is independent of the others. 

What Is The Lab? 

The lab is just a collection of these agent instances in a realistic scenario. This implies that: 



❍     the agents will have been running for a while 

❍     the devices will be pre-configured with interesting data 

❍     there may be hidden devices that interact with the shown devices 

References for Further Reading

For more information on Network Management and SNMP, we recommend these books:

❍     Marshall Rose, The Simple Book: An Introduction to Networking Management, Prentice Hall, 1994

❍     David T. Perkins and Evan McGinnis, Understanding SNMP MIBs, Prentice Hall, 1996

❍     David T. Perkins, RMON: Remote Monitoring of SNMP-Managed LANs, Prentice Hall, 1999

❍     William Stallings, SNMP, SNMPv2, and RMON : Practical Network Management, Addison-Wesley, 1996

❍     William Stallings, SNMP, SNMPv2, SNMPv3, and RMON 1 and 2, Addison-Wesley, 1999.
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User Guide

1.  Table of Contents

❍     Overview 

❍     User Reference 

■     Startup 

■     File Menu 

■     Lab Menu 

■     Device Menu 

■     Help Menu 

■     Speed Bar 

2.  Overview

MIMIC Virtual Lab is an easy-to-use, data-driven interface to MIMIC Simulator. It presents a simulated lab environment consisting of multiple simulated 

devices, which you can manage just like real devices. 

Where other components of the MIMIC suite emphasize power and flexibility, MIMIC Virtual Lab strives to hide MIMIC from the user. This interface is thus 

ideal for users who need a transparent, ready-made virtual lab. The interface allows to start/stop the lab, or individual devices, and a handful of other useful 

functions to manipulate the lab. 

3.  User Reference
Startup

Invoke vlab from a shell command prompt with 

vlab* 

or in Windows from the MIMIC program group in the taskbar, or by double-clicking on the vlab*.bat icon in Windows Explorer. 

(*) the vlab will usually have a number, eg. vlab1. 

The lab configuration file is read and the main panel displays the loaded topology. 



 

Figure 1 - MIMIC Virtual Lab Front Panel 

File Menu

The File menu lets you load or save lab configurations and exit from the program. 

 

File->Load... 

Load a different lab configuration. This is only enabled for products that allow to load different lab configurations (such as Virtual Lab Enterprise). 

File->Reset... 

Reset any changes and cause a restart of all the devices, so that you can go back to the installed defaults. Notice that this does NOT cause a clearing of the 

device configuration, but the simulation data reverts to the state it was when first installed. 

File->Exit 

Exit the lab. You will be prompted to save any changed state for the next restart of the lab. 



Lab Menu

The Lab menu lets you manipulate the loaded lab. 

 

Lab->Refresh 

Sometimes you need to refresh the panel. 

Lab->Start 

This menu item is equivalent to turning power on. Each device is powered up and ready to access. Notice that each device will take on an initial state, which 

may be different from just powering it on. For example: 

❍     the device may have been running for a while; 

❍     the device may have loaded a running configuration with the copy IOS command; 

❍     the device state may have been changed if you saved it from a previous run. 

Lab->Stop 

This menu item is equivalent to turning power off, but may do more. Each device is powered down so it is no longer accessible. If its state has changed, you 

will have the option of saving this state so that on the next start you can continue as if it had never been stopped. Notice: 

❍     on the next start, devices do not reconfigure with saved device configuration files, such as IOS startup-config files. 

❍     to reload a device with a saved configuration file, you need to use the device's reloading procedure, such as running IOS reload command. 

Lab->Exercise... 

This dialog lets you run exercises in the virtual lab. An exercise consists of a number of steps which accomplish desired dynamic changes to the lab. The 

dialog shows an Exercises tree, with 2 top-level nodes Start and  Active. In general, if a node has an icon in front of it or is in bold text, you can find 

out more about it by placing your cursor on it. A hint popup gives you more information. 

Selecting one of the  Eligible exercises under Start followed by a click of the  Start button will activate that exercise for the selected device. Clicking 

the  Continue button a halted exercise under  Active will continue to the next step in that exercise. 

You can check details for an exercise by opening its node (click the + icon in front of it). The Description node describes the exercise in general terms, the 

First Step, Next Step, Status and Completed items describe the state of the exercise. 

You can double-click on the  Help node in an exercise to display its online documentation. When you finish with an exercise (you cannot click  

Continue anymore), you have to double-click on  Cleanup to dismiss the exercise. You can double-click on the  Abort node to prematurely end an 

exercise. Double-clicking on  Diagnostic Log is only necessary in case of trouble-shooting, and displays a Log window. 

Once an eligible exercise is no longer interesting, you can hide it by double-clicking the  Hide node. If hidden, it will continue to appear under the  

Ineligible node, where you can restore it to be eligible with the  Unhide node. Exercises can also be ineligible for other reasons. To determine why an 
exercises is ineligible, open its Reason node. One reason could be that you need to select a device to run the exercise on. 



 

Figure 2 - Lab Exercise Dialog 

Lab->Info... 

The General tab displays detailed information about all devices. The Traps tab allows to enter trap destinations. The Statistics tab displays detailed 

statistics for the devices present in the lab. 

Lab->Troubleshoot... 

To aid in troubleshooting, the log window captures the diagnostics output for MIMIC Virtual Lab. All informational and error messages are displayed and 

output to a file given in the title of the window. This log window or output file should be referred to whenever you have problems with MIMIC. 



 

Figure 3 - MIMIC Log Window 

All log files are placed in /tmp/ and are ordered by date of invocation. The log file contains additional message details, which are filtered out in the log window 

for legibility. 

In the log window, each diagnostic message is listed with the following severities: 

1.   INFO    - informational message (shows progress, no impact on correctness of results) 

2.   WARN   - warning message (some impact on correctness of results) 

3.   ERROR - error message (more impact on correctness of results; possibly fatal) 

NOTE: Severities are subjective under most circumstances. In general, you can ignore warnings, unless your management application relies on correctness of 

the impacted part of the simulation. Error messages merit closer inspection. 

Certain messages are multi-line because the underlying cause of the event is also logged. This leads to more accurate diagnosis of the problem. Multi-line 

messages are shown with a leading + sign. For legibility the log window shows only the first line of the diagnostic message. The causes of any error message 

can be expanded by clicking on the + or double-clicking on the message itself. 

The log window will be displayed until you select File->Close. 

A single selected message or a set of messages can be copied using Edit->Copy and then pasted into other applications. This makes it easy to e-mail related 

error message information to help Gambit support personnel diagnose your problem. 

You can filter out existing messages from being displayed: 



❍     Filter->Message filters out the individual selected message(s). 

❍     Filter->Type filters out all messages of the same type as the selected message(s). 

❍     Filter->Severity filters out all messages of the same severity as the selected message(s). 

❍     Filter->Off turns off filtering for selected messages and (re)displays them. 

The Options menu lets you change the way the log window behaves. You can turn off the tracking of the end of the log (the "tail") by deselecting the Tail 

item, and you can turn on the expansion of nested messages with the Nested option. 

The most common error messages are listed in Appendix C. 

Lab->Addresses... 

This menu item will invoke the dialogs to change IP addresses in your lab. This procedure is invoked the first time you run your lab, and should only be 

performed after that if the selected addresses clash with some part of your network. 

Device Menu

The Device menu lets you manipulate the selected device. 

 

Device->Start 

This menu item starts the selected device, which is equivalent to powering it up. First the device icon border will turn cyan, indicating that the device 

simulation is starting. When the device icon shows green, the device is fully started and ready to be accessed. 

Device->Stop 

This menu item stops the selected device, which is equivalent to powering it down, but may do more. When the device icon shows red, the device is fully 

stopped and cannot be accessed. If its state has changed, you will have the option of saving this state so that on the next start you can continue as if it had 

never been stopped. 

Device->Console... 

You can use this menu item to conveniently log into the device. The console client window pops up and you can login to the device. The console client 

attempts to simulate as closely as possible the real-world behavior of the console port. 

Device->Telnet... 

You can use this menu item to conveniently telnet into the device. The telnet client window pops up and you can login to the device. Of course you can use 

any other telnet client to access the device. 

Device->Info... 

This menu item displays more information for the selected device, such as its interfaces in the General tab, the SNMP attributes (port and community strings) 

in the SNMP tab, and telnet attributes (user and password for the different IOS modes) in the Telnet tab. 

Device->MIB... 

This dialog visualizes the MIB of the selected device. It shows a MIB Browser on the left, which displays a tree diagram of the MIB object hierarchy. Each node 

in the tree is either a subtree or a leaf MIB object. 



 

Figure 4 - Device MIB Dialog 

You can open subtrees in the hierarchy by double-clicking on branch nodes that are preceded by a plus (+) box, or by single-clicking on the plus box itself. 

You can close subtrees by single-clicking on the minus (-) box before a branch node. 

MIB object leaf nodes contain information for the object. A symbol denotes the type of the MIB object. These are the currently displayed object types: 

❍      - Integer 

❍      - OctetString 

❍      - Counter, Counter64 

❍      - Gauge 

❍      - IpAddress 

❍      - OBJECT IDENTIFIER 

❍      - TimeTicks 

❍      - SNMPv1 Trap 

❍      - SNMPv2 Trap 

❍      - Address 

❍      - BITSTRING 

❍      - NetAddress 

❍      - Opaque 

In addition, the color indicates the access to the object: 

❍     gray - read-only, not-accessible, accessible-for-notify 

❍     green - read-write, write-only 

❍     yellow - read-create 

You select a MIB object by clicking on the leaf node in the tree. 



You can type a object name in the Object field, and click the Find button to directly select it. 

For example, for the outgoing octets counter of a network interface you would use ifOutOctets. 

The right side contains a matrix, which displays all columns in a MIB table, or scalar objects underneath a branch. Clicking (Shift-left mouse button) on the 

top row expands or contracts the width of a row between 3 possible states: wide enough to display all values in the column, 10 characters wide, contracted. 

Clicking on a value has no effect - the edit mode is allowed to inspect the entire value. 

To redisplay the value (eg. to monitor increasing Counter objects), just click on the object and the values will be updated. 

Connection Menu

The Connection menu lets you manipulate the selected connection. 

 

Connection->Disconnect 

This menu item disconnects the link. This is analogous to unplugging a cable at either end, or physically cut it. The MIMIC Virtual Lab will attempt to simulate 

this condition just like in the real world. The link will be shown with a dashed line. 

Connection->Reconnect 

This menu item reconnects the disconnected link. This is analogous to plugging the cable in at both ends. 

Connection->Remove 

This menu item removes the selected link. This is analogous to removing the cable entirely. The difference between disconnecting and removing the cable is 

that the latter allows connecting a different cable to a different port to either end. 

Connection->Add 

Selecting an unused port (ie. no cable connected to it) and clicking this menu item highlights all the ports that this port can be connected to. Once you select 

the second end-point, a cable will be drawn to connect them. Initially the cable will be unplugged, but you can reconnect it to gain connectivity between the 

ports. 

Help Menu

The Help menu displays online documentation and revision information. 

 

Help->Contents... 

The HTML documentation is displayed in your HTML browser of choice. 

Help->Update... 

This menu item invokes the Update Wizard. 

❍     Introduction

The Update Wizard makes it easier to update to newer versions of MIMIC over the Internet, or to install optional software from CD-ROM. It automatically notifies you of 

new software updates, and presents a friendly front-end to install them. 



MIMIC Virtual Lab will notify you of the availability of new updates of MIMIC. This occurs whenever you start MIMIC Virtual Lab, but at most once a day. 

MIMIC Virtual Lab will download the MIMIC update database, and check for applicable updates to your software. 

If there are new updates, you will be notified with a dialog. This lets you either: 

■     update immediately, by invoking the Update Wizard. 

■     update later. You have to manually invoke the Update Wizard from the Help->Update... menu. 

■     don't notify. This turns off the automatic update notification feature. 

First you need to select the source of your update, either from the Gambit Web site, or from CD-ROM. Since the CD-ROM can be at a different directory 

path on each system, you will need to supply it's location in the Path field. 

4.  Select Update

A log window similar to the one displayed by Lab->Troubleshoot is displayed which logs all steps taken in the update. 

In this dialog, select the update you want to install for your version of MIMIC. If there are no applicable updates, you are done. 

Pressing Next downloads the update. 

5.  Download Images

The update is downloaded from the Gambit Communications Web site. The download progress is displayed on the Status and Progress bars at the bottom. 

If the update has already been downloaded, you are asked whether to download again. 

If the extraction tools (gzip, tar) are not executable, they are also downloaded. 

6.  Prepare For Installation

Certain updates need extra preparation to complete the update. This is done here. You will be prompted for any extra steps. 

7.  Extract Files

Files are extracted from the update. The list of files is displayed for your information. 

Pressing Next extracts the contents of the update, and moves files to the shared area. Any existing files are backed up. 

8.  Move Files

First, the contents of the update are extracted into a temporary directory. Then files are moved from the temporary directory to the shared area. 

While files are being moved, the progress is displayed on the Status and Progress bars. 

Help->About... 

This displays the revision and contact information. 

Speed Bar

The Speed Bar provides quick access to the most common commands. The action performed by each button will be displayed in a pop-up window under the 

Speed Bar when the cursor is positioned over the button. 

Start the entire lab. This menu item is equivalent to turning on the power for all the devices in the lab. 

Stop the entire lab. This menu item is equivalent to turning off the power for all the devices in the lab. 

Start the selected device. This menu item is equivalent to turning on the power for the selected device. 



Stop the selected device. This menu item is equivalent to turning off the power for the selected device. 

Telnet to the selected device. This menu item will open a telnet client window in order to login to the device. 

Display values in MIB. This menu item will display a window with a MIB Browser on the left and a matrix that displays all columns in the MIB table on the 

right. 

Display help contents. This menu item displays the online help and revision information.

Java Configuration

MIMIC needs to know about the Java Runtime Environment (JRE) installed on your machine. It attempts to detect it in the default paths, but you may have to 

point it to the correct location (bin/ subdirectory of the JRE install area). 
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MIMIC Virtual Lab and JRE

●     Requirements 

MIMIC Virtual Lab requires the use of the Java Platform, Standard Edition (Java SE) 6 or later. If you don't have it, 

download it from Sun Microsystems. 
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Appendix A: IOS Commands
This is a partial list of supported commands: 

Router IOS Commands Mode 

? um, en, ct, ci, cm, pm 

< command > ? um, en, ct, ci, cm, pm 

access-list ct, ci, cl 

auto-summary ro 

bandwidth ci 

banner ct 

banner login # ct 

begin um, en 

cdp [enable | holdtime | run | timer] ct 

class pm 

class-map ct 

clear arp-cache en 

clock rate ci 

configure terminal en 

connect um,en 

copy en 

copy running-config startup-config en 

copy startup-config running-config en 

copy tftp flash en 

copy tftp running-config en 

copy tftp startup-config en 

debug all en 

debug dialer [events | packets] en 

debug eigrp [neighbors | packets] en 



debug frame-relay lmi en 

debug ip igrp transactions en 

debug ip ospf [database | events | neighbor] en 

debug ip rip en 

debug isdn q931 en 

deny ipa 

description ci 

dialer [fast-idle | idle-timeout] ci 

dialer map ci 

dialer pool-member ci 

dialer remote-name ci 

dialer string ci 

dialer-group ci 

dialer-list ct 

disable en 

disconnect um,en 

duplex ci 

enable um,ct 

enable [password | secret] en,ct 

encapsulation dot1q ci 

encapsulation frame-relay [cisco | ietf] ci 

encapsulation [isl | ppp] ci 

end ct, ci, cl, cm, ipa, ro 

exclude um, en 

exec-timeout cl 

exit en,ci, ct, ipa 

exponential-weighting-constant ct 

fair-queue ct 

frame-relay ct 

frame-relay adaptive-shaping {becn | foresight} mc 

frame-relay bc [in | out] bits mc 

frame-relay be [in | out] bits mc 

frame-relay cir [in | out] bps mc 

frame-relay idle-timer [in | out] seconds mc 



frame-relay intf-type ci 

frame-relay lmi-n392dce threshold ci 

frame-relay lmi-n393dce events ci 

frame-relay lmi-t393dce seconds ci 

frame-relay lmi-type ci 

frame-relay route ci 

frame-relay switching ct 

help um, en, ct, ci, cm, pm 

hostname ct, ci, cl, cm, ipa, ro 

interface ct, ci 

ip access-group ci 

ip access-list ct 

ip address ci 

ip classless ct 

ip default-gateway ct,cm 

ip host ct 

ip mtu ci 

ip nat inside source ci 

ip nat outside source ci 

ip nat pool ct 

ip nat translation ct 

ip ospf cost ci 

ip route ct 

ip router isis ci 

ip routing ct 

ip summary-address eigrp ci 

ipv6 ct, ci 

ipv6 address ci 

ipv6 rip enable ci 

ipv6 router ct 

ipv6 unicast-routing ct 

isdn switch-type ct, ci 

keepalive (f/r lmi command) ci 

line ct 



line aux 0 ct 

line console 0 ct 

line vty 0 4 ct 

logging ct 

login cl 

logout um,en 

mac-address ci 

map-class ct 

match cm 

neighbor remote-as ro 

net (is-is) ro 

network (bgp) ro 

network (eigrp) ro 

network (rip) ro 

no access-list ct 

no banner ct 

no banner login ct 

no cdp enable ci 

no cdp holdtime ct 

no cdp run ct 

no cdp timer ct 

no clock rate ci 

no debug eigrp packets en 

no description ci 

no dialer-list ct 

no duplex ci 

no enable password ct 

no encapsulation ci 

no frame-relay switching ct 

no ip access-group ci 

no ip address ci 

no ip classless ct 

no ip default-gateway cm 

no ip host ct 



no ip nat inside source ci 

no ip nat outside source ci 

no ip nat pool ct 

no ip nat translation ct 

no ip ospf cost ci 

no ip route ct 

no ip router isis ci 

no ip summary-address eigrp ci 

no ipv6 ct, ci 

no ipv6 address ci 

no ipv6 rip enable ci 

no ipv6 router ct 

no ipv6 unicast-routing ct 

no isdn switch-type ct, ci 

no keepalive (f/r lmi command) ci 

no logging ct 

no login cl 

no mac-address ci 

no neighbor remote-as ro 

no net (is-is) ro 

no network (bgp) ro 

no rate-limit ci 

no router bgp ct 

no router eigrp ct 

no router igrp ct 

no router isis ct 

no router ospf ct 

no router rip en 

no shutdown ci 

no snmp-server ct 

no snmp trap ci 

no snmp trap link-status ci 

no trunk group ci 

permit ipa 



ping um,en 

police pm 

policy-map ct 

ppp authentication ci 

priority cl 

queue-limit ct 

random-detect ci 

rate-limit ci 

reload en 

remark ipa 

router bgp ct 

router eigrp ct 

router igrp ct 

router ospf ct 

router rip ct 

service-policy ci, cl, cm, mc, pm 

show access-lists um,en 

show arp um,en 

show backup um,en 

show buffers um,en 

show cdp um,en 

show cdp entry * um,en 

show cdp entry name um,en 

show cdp interface um,en 

show cdp neighbors um,en 

show clock um,en 

show compress um,en 

show configuration en 

show controllers um,en 

show dialer um,en 

show flash all um,en 

show flash chips um,en 

show flash detailed um,en 

show flash err um,en 



show flash summary um,en 

show frame-relay lmi um,en 

show frame-relay map um,en 

show frame-relay pvc um,en 

show frame-relay route um,en 

show history um,en 

show hosts um,en 

show interface [type|type n/n] um,en 

show ip access-lists en 

show ip aliases um,en 

show ip arp um,en 

show ip bgp um,en 

show ip eigrp neighbors um,en 

show ip eigrp topology um,en 

show ip interface um,en 

show ip nat en 

show ip ospf um,en 

show ip protocols um,en 

show ip rip um,en 

show ip route um,en 

show ip route bgp um,en 

show ip route eigrp um,en 

show ip route ospf um,en 

show ip route rip um,en 

show ipv6 um,en 

show ipv6 interface um,en 

show ipv6 rip um,en 

show ipv6 route um,en 

show isis um,en 

show location um,en 

show logging um,en 

show modemcap um,en 

show protocols um,en 

show running-config en 



show running-config interface en 

show snmp um,en 

show startup-config um,en 

show terminal um,en 

show users um,en 

show users all um,en 

show users wide um,en 

show version um,en 

shutdown ci 

snmp trap ci 

snmp trap link-status ci 

systat um, en 

systat all um,en 

terminal history size um, en 

terminal length um, en 

terminal width um, en 

traceroute en 

trunk group ci 

undebug all en 

where um 

Switch IOS Commands Mode 

access-list ct 

banner ct 

cdp ct, ci 

clear arp-cache en 

clear port-security en 

configure en 

connect en 

copy en 

debug en 

description ci 

disable en 

disconnect en 

duplex ci 



enable en 

enable password ct 

enable secret ct 

end ct, ci, cl, ipa 

exit en, ct, ci, ipa 

help um, en, ct, ci, ipa 

hostname ct, ci, cl, ipa, vl 

interface ct 

ip ct 

ip access-list ct 

ip default-gateway ct 

ip host ct 

ipv6 ct, ci 

ipv6 address ci 

ipv6 rip enable ci 

ipv6 router ct 

ipv6 unicast-routing ct 

line ct 

logging ct 

logout um, en 

mac-address aging-time ct 

mac-address static ct 

mac-address-table ct 

no en, ct 

ping um, en 

random-detect ci 

reload en 

show access-lists en 

show arp en 

show buffers en 

show cdp en 

show clock en 

show configuration en 

show flash: en 



show history en 

show hosts en 

show interfaces en 

show interfaces switchport en 

show interfaces vlan en 

show ip en 

show ipv6 en 

show location en 

show logging en 

show mac-address-table en 

show port-security en 

show running-config en 

show snmp en 

show spanning-tree en 

show startup-config en 

show terminal en 

show users en 

show version en 

show vlan en 

show vtp status en 

shutdown ci 

snmp-server ct 

switchport access vlan ci 

systat en 

telnet um, en 

terminal en 

traceroute en 

trunk ci 

vlan ct 

vlan database en 

vtp vl 

where um, en 

Catalyst Switch Commands Mode 

show trunk en 



clear trunk en 

set interface en 

set trunk en 

Modes

um = User EXEC mode 

en = Privileged EXEC mode (enable command) 

ct = Global Configuration mode (configure terminal command) 

ci = config-if mode (interface command) 

cl = config-line mode (line command) 

cm = config-cmap mode (class-map command) 

ipa = ip access-list configuration (named access-lists) 

mc = map-class 

pm = policy-map 

ro = router config 

vl = VLAN 

For details see, eg. Cisco IOS 12.4 Documentation. 

<< Previous Section    Next Section >> 
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Appendix C: Common Error Messages

Since MIMIC is an extremely complex tool, it was designed to contain extensive diagnostic information. All events of 

interest are logged and displayed in the log window viewable through the Lab->Troubleshoot menu item. Since we cannot 

display a detailed explanation with every message at runtime, they are listed here. 

Information that can change from message to message is shown in BOLD. 

To use the list, search it by some unique words in the message (this should stay the same across releases). 

If you don't see a message explained here, please cut and paste it into an e-mail message and send it to 

support@gambitcomm.com. We will include it in the next rev of the documentation. 

Agent Simulator

1.  ERROR DATE - agent NUMBER cannot read PDU from ADDRESS 

      DATE - snmp_agent_parse failed 

      DATE - unknown community: COMMUNITY 

Cause 

An SNMP request with a community string was received which differs from the configured community string for the agent 

instance. 

Action 

The SNMP request is ignored. To accept requests at the community, change the agent instance configuration. 

2.  ERROR DATE - agent NUMBER cannot read PDU 

      DATE - snmp_agent_parse failed 

      DATE - Bad Version: 1 

Cause 

An unknown SNMP protocol is being used. MIMIC currently only supports SNMPv1. Some management applications (like 

HP/OpenView) may want to talk a different protocol, such as the newer SNMP Security Protocol, which has not been 

standardized), and usually first try it, then fall back to SNMPv1. 

Action 

The SNMP request is ignored. 

3.  ERROR DATE - no receiver at ADDRESS 

Cause 

This message means an SNMP request was received for an address that has no agent instance running. This request could 

mailto:support@gambitcomm.com


be for the host's real IP address, in which case this message happens occasionally. 

Action 

The SNMP request is ignored. 

4.  WARN  DATE - cannot receive from ADDRESS. continuing... 

      DATE - recvfrom: Connection refused 

WARN  DATE - cannot receive from ADDRESS. continuing... 

      DATE - recvfrom: Resource temporarily unavailable 

WARN  DATE - cannot receive from ADDRESS. continuing... 

      DATE - recv: No error 

ERROR DATE - agent NUMBER send failed from ADDRESS to ADDRESS 

      DATE - type=NUMBER size=NUMBER 

      DATE - sendto: Connection refused 

WARN  DATE - cannot accept connection from ADDRESS. continuing... 

      DATE - accept: Resource temporarily unavailable 

Cause 

Any of these messages means a protocol request (SNMP, Telnet, TFTP, etc) or connection was aborted by the management 

application. This happens occasionally, and could be an indication of a faulty management application. 

Action 

The request is ignored. 

5.  ERROR DATE - AGNT[x]: cannot start(2) agent NUMBER 

      DATE - Please refer to Appendix C for more details ERROR DATE - cannot bind receive IP address 

      DATE - bind: Permission denied 

Cause 

This message means that you are running without sufficient privileges to bind to the selected SNMP socket. 

Action 

You need to run the MIMIC daemon mimicd with sufficient privileges. 

On Unix, this means running mimicd as root, or with setuid-root. The installation by default installs mimicd as setuid-root. 

On Windows NT, you need to run MIMIC as a user with Administrator privileges. 

6.  ERROR DATE - AGNT[x]: cannot start(2) agent NUMBER 

      DATE - Please refer to Appendix C for more details 

      DATE - cannot bind receive IP address ADDRESS port PORT 

      DATE - bind: no error 

Cause 

This message on Windows NT means there is already another process running that uses the selected SNMP port. This is 

very likely an already-running instance of an SNMP agent. 

On Windows 2000 and XP it could also mean that you are trying to use an IP address that is already assigned to another 

node running on the network. See Windows Installation Guide for more details. 



Action 

Only one process can simultaneously use the selected SNMP port on a host. 

To verify if there is such a program, stop MIMIC with File->Terminate and use the netstat utility from the DOS command 

line prompt, for example: 

C> netstat -a -n | find "161" 

TCP 0.0.0.0:161 0.0.0.0:0 LISTENING 

UDP 0.0.0.0:161 *:* 

If these lines show, then start the Windows task manager and see if there is an SNMP agent process running, e.g. snmp.

exe, that you need to kill. 

Otherwise, contact Technical Support on how to find any other programs using this port. 

The Windows NT SNMP service can only be killed from the Services control panel. 

7.  ERROR DATE - AGNT[x]: cannot start(2) agent NUMBER 

      DATE - cannot set address 

      DATE - cannot add address ADDRESS 

      DATE - Cannot add IPAddress ADDRESS 

      DATE - Failed DhcpNotifyConfigChange. 

Cause 

You can only run MIMIC from an account with Administrator privileges. Consult the Windows Installation Instructions 

section for details. 

Action 

Login to an account with Administrator privileges and run MIMIC. 

8.  ERROR DATE - AGNT[x]: cannot start(2) agent NUMBER 

      DATE - cannot set address 

      DATE - cannot add address ADDRESS 

      DATE - AddIPAddress failed. Reason=A device attached to the system is not functioning. 

ERROR DATE - AGNT[x]: cannot start(2) agent NUMBER 

      DATE - cannot set address 

      DATE - cannot add address ADDRESS 

      DATE - Cannot add IPAddress ADDRESS 

      DATE - DeleteIPAddress failed. Reason=The specified network resource or device is no longer available. 

Cause 

This error means that the network interface configured for the agent is not available, and usually happens on laptop 

computers, where you can pull out network cards (PCMCIA, docking stations), or on newer versions of Windows, when the 

network is unplugged. Consult the Windows Installation Instructions section for details. 

Action 

Configure a different network interface for the agent. 

9.  ERROR DATE - cannot listen on remote management socket 



      DATE - listen: No error 

Cause 

On Windows, this likely means you are running a software firewall which is preventing MIMIC from running properly. 

Action 

Configure your software firewall to allow MIMIC to access the network. See also the Windows Installation Instructions. 

10.  ERROR DATE - initialization failed 

      DATE - Cannot read license 

ERROR DATE - initialization failed 

      DATE - License expired 

ERROR DATE - initialization failed 

      DATE - cannot get license 

      DATE - Invalid license key 

ERROR DATE - initialization failed 

      DATE - cannot get license 

      DATE - License corrupt 

Cause 

The licensing information in the license file mimicd.lic is incorrect. 

Action 

MIMIC will not run without correct license keys which you can obtain from support@gambitcomm.com. 

You can copy/paste the keys when prompted by the installation program. Or, if you have already installed MIMIC, then edit 

the config/*.lic files to paste the correct key (also see FAQ). 

11.  ERROR: oid.cc:47: assertion failed - constructor failed 

Cause 

Any assertion failure is fatal, and should be reported to support@gambitcomm.com. Any message with "constructor failed" 

is likely a lack of virtual memory. You need to increase your swap space as detailed in the OS-specific installation 

instructions. 

Action 

Send email to support@gambitcomm.com. 

12.  ERROR DATE - buffer full from ADDRESS to ADDRESS 

Cause 

The "buffer full" message is displayed when the management application sends too many requests at once. MIMIC cannot 

service them all, and buffers them (as all real SNMP agents do). The message alerts you when the buffer overflows, and 

messages are discarded (as all real SNMP agents do, except they do it silently). 

Action 

This condition can be caused due to 2 reasons: 

a) MIMIC is too slow (running on a underpowered machine). If this message occurs occasionally, you can overcome this 

problem by either putting MIMIC in overdrive by disabling action scripts, and/or increasing the buffer size for each agent. 

If you are not using action scripts, you can disable the extra processing on every received request, resulting in significant 
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performance gain. To disable actions, set the MIMIC_DISABLE_ACTION environment variable to any value prior to running 

MIMIC (if it is running, you must terminate it with File->Terminate from MIMICView). 

In the C shell, do: 

% setenv MIMIC_DISABLE_ACTION 1 

In the Bourne shell, do: 

# MIMIC_DISABLE_ACTION=1; export MIMIC_DISABLE_ACTION 

On Windows NT, use the System Control Panel to set this environment variable. 

To increase the buffer size for each agent, edit the config/mimicd.cfg file and add a line 

agent_qsize = value 

where "value" is a number larger than 10 (the default). Try 20. 

If this problem persists, you may want to run MIMIC on a more powerful machine. 

b) the management application has a performance bug, ie. it sends too many requests simultaneously (as we have seen). 

A real agent will never alert you to this condition, except that performance suffers, since the app will retransmit the 

discarded requests. 

A common bug in management applications is the issuance of too many simultaneous requests in a "burst". Performance 

bugs are violations of the performance requirements for managing devices. These are subtle bugs, since their only 

symptoms are degraded performance, which is hard to measure. MIMIC helps you detect these violations. 

An example of this condition is "agressive retransmission policy", which could trigger this effect: the app is sending a 

request, which may be delayed. The app times out, and retransmits. If this happens more than a certain number of times 

consecutively, the buffer overflows. This is independent of the overall rate. 

A short protocol analyzer session would verify this: Gambit ships a free (unsupported) protocol analyzer called tcpdump 

downloadable from http://www.gambitcomm.com/unsupported . If you run tcpdump as follows from root: 

# tcpdump -s 256 -n host agent-IP-address and port 161 

it will dump all SNMP packets to/from that agent IP address. Run this analyzer until the buffer full error happens. Then 

send us the output. 

An aggressive retransmit policy could be a bug in the application, ie. it will have performance problems interacting with 

any agent, whether MIMIC or anybody else's. 

13.  WARN  DATE - USM Error: sending report PDU 

      DATE - unknown engine id: "" 

Cause 

This warning is an indication that the management application did a discovery of the SNMPv3 engine ID from the agent: in 

order to detect the engine ID it sends an illegal engine ID, causing the agent to respond with an unknownEngineID 

REPORT PDU. 



Action 

None necessary, if your SNMPv3 management application works correctly. Otherwise, you may have to do manual 

configuration of the engine ID. 

14.  WARN  DATE - agent NUMBER cannot remove primary alias 

      DATE - no receiver thread for socket NUMBER 

WARN  DATE - cannot clear pollfd NUMBER 

      DATE - T[x], socket NUMBER not registered 

WARN  DATE - cannot clear pollfd NUMBER 

      DATE - T[x], socket NUMBER not found in map 

WARN  DATE - NR[x]: continuing poll on agents... 

      DATE - socket NUMBER not registered 

WARN  DATE - cannot switch socket NUMBER to inactive thread, continuing... 

      DATE - command buffer overflow 

Cause 

Any of these messages indicates temporary problems in the protocol dispatcher in the simulator. These messages happen 

occasionally, under extreme stress of the simulator. 

Action 

The messages indicate a recovery action by the simulator, and may result in dropped messages to the agents. No action is 

necessary, unless the messages happen frequently. If they do, please contact support@gambitcomm.com to remedy the 

problem. 

15.  ERROR DATE - PROTOCOL [AGT=NUMBER]: cannot start server 

      DATE - cannot enable IP address for 

      DATE - cannot start ipalias 

      DATE - cannot open socket 

      DATE - Please refer to Appendix C for more details 

      DATE - cannot bind receive IP address ADDRESS port PORT 

      DATE - bind: Address already in use. 

Cause 

This error means that there is already a service running on the indicated port, eg. there is already a Telnet service running 

on port 23. Only one service can be bound to a port at a time. On Linux systems, the Telnet service is managed with 

xinetd. 

Action 

You have 2 options: 

1.  start the MIMIC protocol server on a different port. Eg. start the telnet server on port 2423. 

2.  disable the platform-native Telnet service. On Linux systems, this can be accomplished with /usr/sbin/setup, in the System 

Services menu, or via chkconfig. 

<< Previous Section    Next Section >> 
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MIMIC Virtual Lab Frequently Asked Questions
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Save the latest FAQ page into your MIMIC installation help/ directory to make it an integral part of your online documentation. 
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General 

1.  Q. What is a "gambit"? 

2.  Q. What are the hardware considerations for running MIMIC? 

3.  Q. Can I run MIMIC Virtual Lab on Windows 7? 

4.  Q. Can I run MIMIC Virtual Lab on Windows 95 / 98 / Me? 

5.  Q. Do you have any SNMP tools for Windows? 

6.  Q. How do you customize and program MIMIC? 

7.  Q. How can I trace PDU exchanges between my management application and MIMIC? 

8.  Q. What is the best way of reporting problems with MIMIC? 

9.  Q. Is there a way to modify the configuration of MIMIC to use another drive for its use? 

10.  Q. Will there be a port conflict if I install the MIMIC software on a machine with HPOV Network Node 

Manager 5.01 installed? 

11.  Q. Why does HPOV Network Node Manager not discover the MIMIC agents? 

12.  Q. Can you run MIMIC and a Web Server on the same machine? 

13.  Q. How do I apply new license keys to the installed software? 

14.  Q. Why is my firewall warning me about access to the Internet? 

Simulator 

1.  Q. I cannot start agents in MIMIC. I get errors in the log when starting an agent instance. Why? 

2.  Q. I have started agents in MIMIC, but I cannot ping them from my management station. Why? 
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3.  Q. When I run a simulation, I see some diagnostic messages in the log window. What do they mean? 

4.  Q. I am seeing the message "buffer full from ADDRESS to ADDRESS" in the error log. What does it mean? 

5.  Q. How do I change the look and feel of the user interface? 

General 
Q. What is a "gambit"? 

A. A "gambit" is a term from the game of chess, a risky opening move with high potential return. Also see Merriam-

Webster Dictionary: 

Main Entry: gam·bit

Pronunciation: 'gam-b&t

Function: noun

Etymology: Italian gambetto, literally, act of tripping someone, from gamba

leg, from Late Latin gamba, camba, from Greek kampE bend; probably akin to

Gothic hamfs maimed, Lithuanian kampas corner Date: 1656

1 : a chess opening in which a player risks one or more minor pieces to

  gain an advantage in position

2 a (1) : a remark intended to start a conversation or make a telling point

    (2) : TOPIC

  b : a calculated move : STRATAGEM

Q. What are the hardware considerations for running MIMIC? 

> In your support page, you give the minimum hardware configuration and

> the preferred hardware configuration, but the number of agents simulated

> doesn't seem to be taken into account. I mean is the hardware configuration

> the same for all the versions of MIMIC (MIMIC Single, MIMIC Lite, ...,

> MIMIC Global) which simulate different numbers of agents?

A. The preferred configuration listed on the web page is for a typical case. MIMIC Virtual Lab will run in any run-of-the-mill 

PC better than the minimum configuration listed. For MIMIC Simulator, read on. 

Obviously, the more demanding the simulation, the more hardware you have to throw at it. The main thing to realize is 

that the hardware requirements for MIMIC can be viewed as satisfying an equation, eg. 

performance (management side) <= performance (agent side)

meaning that the performance of the agent side (MIMIC) has to be at least as good as that needed by the management 

side. The performance requirements are thus driven in large part by the management application. The second point is that 

the equation is not controlled by a single variable (eg. "requests per second"). There are many variables which determine 

the exact demands on the simulation: 

●     the number of agents 

http://www.m-w.com/dictionary.htm
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●     the set of MIBs for each agent 

●     the complexity of the simulations for the different MIB objects 

●     the trap generation rates 

●     the number of management threads (eg. pollers) 

●     the poll rates (average, sustained, peak) 

●     the make-up of the requests (single-variable vs. multi-variable vs. bulk) 

This is just a partial list, but gives you an idea of the considerations. Ultimately, there is no generic answer and each 

customer has unique performance requirements. We can help you to determine these requirements through empirical 

evaluation. Your requirements may change over time, so your hardware solution should accomodate this change (more 

CPUs, more memory, more network cards). MIMIC is designed to take advantage of all the hardware you throw at it. 

MIMIC supports up to 10,000 agents on one workstation. The main concern is the performance for a fully loaded 

workstation. You want at least hundreds of PDUs per second to make a simulation viable. 

For MIMIC, performance is primarily governed by the amount of physical memory (RAM). The memory requirements 

depend on the simulations you are going to run. Obviously, a high-end router simulation with hundreds of interfaces, 

RMON tables, etc. is going to take more memory than the simulation of an end system. 

As a ball-park estimate, we like to see at least 1MB of physical RAM per simulated agent, e.g., a 100 agent scenario should 

run fine on a 128MB system (depending on how much memory is used by the OS and other processes). For better 

performance (less swapping), 2MB per simulation is recommended. 

After version 4.30, MIMIC has a new feature - memory optimization. That means more agents' MIB data needs less 

memory than before. Agents with identical simulation will only require one copy of data in memory. For example, in the 

common case if 10,000 agents are identical, only a couple of MB of RAM is needed. However, if 5000 agents are running 

the same simulation, and 5,000 agents are each different, then 5GB will be recommended. 

You can more accurately measure this by running a simulation configuration, and checking on memory usage before and 

after starting the desired agent simulations. Notice that MIMIC uses memory on demand, so you should measure the 

memory after doing a walk of the desired tables (or a complete MIB walk). Eg. on Windows NT use the Windows Task 

Manager to check "Memory Usage", and on Unix use the "top" utility. 

The memory usage by MIMIC is approximately the same for all platforms. 

The CPU is of secondary importance. Most modern processors (e.g., Intel Pentium 800MHz or faster, and Ultra Sparc) are 

adequate. MIMIC works with multi-processor systems, since it is a multi-threaded, distributed application. Agent thread 

processing will be distributed across multiple CPUs. From our internal experience, we have run 10,000 agents on dual and 

quad-CPU Pentiums, and Ultra 10 to E4500 Sparcs. 

The final bottleneck would be the network pipe to your agents. 10Mb Ethernet is adequate for low-volume traffic, 100Mb or 

faster is better for more demanding applications. MIMIC works with multiple network adapters on your system, so you can 

talk to the simulations over separate network pipes. MIMIC works with the OS-native protocol stacks, so that all network 

interface cards that your OS supports can be used. You can even run MIMIC over PPP. 



Q. Can I run MIMIC Virtual Lab on Windows 7? 

A. MIMIC Virtual Lab based on MIMIC Simulator 10.20 or later supports Windows 7. 

Q. Can I run MIMIC Virtual Lab on Windows 95 / 98 / Me? 

A. There is no support for MIMIC Virtual Lab on Windows 95 / 98 / Me as documented in the online documentation 

Windows Installation Instructions. 

Q. Do you have any SNMP tools for Windows? 

A. You can download an unsupported binary distribution of the Net-Snmp (was UCD SNMP) toolset from our website. 

Q. How do you customize and program MIMIC? 

> Also, how is MIMIC programmed?  What programming language?  Tcl?

> Scripts?  What type of development environment?  How customizable is it?

MIMIC Virtual Lab is a static environment, but MIMIC Simulator is highly customizable. Check for details at our web site. 

Q. How can I trace PDU exchanges between my management application and MIMIC? 

A. Tcpdump is a free public domain protocol analyzer. Most Linux distributions include this valuable diagnostic tool. You 

can download an unsupported binary executable with SNMPv1 and SNMPv2 support from our website for Solaris. 

Ethereal is a great free public domain protocol analyzer. It decodes SNMPv3. Download it for your favorite platform from 

their website http://www.ethereal.com/. 

Q. What is the best way of reporting problems in MIMIC? 

A. The fastest way of resolving problems is by sending e-mail to support@gambitcomm.com with a brief description of the 

problem, and supporting information, such as excerpts from the log window that show the problem. 

If there is a workaround, we will let you know as soon as possible. If the problem requires a fix, we will open a trouble 

ticket and schedule it for an upcoming release. All customers are notified of new releases as soon as they become 

available. 

If you have a large supporting file from one of the tools (core file, log file, walk file), please don't email it yet since our 

mail server has limited resources (bandwidth and space). Tell us about the problem first, and we will ask you for the core 

file. 

http://sourceforge.net/projects/net-snmp
http://www.gambitcomm.com/unsupported/
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Q. Is there a way to modify the configuration of MIMIC to use another drive for its use? 

        The problem: the drive that MIMIC is using has become full due

        to MIMIC usage. Is there a way to modify the configuration of

        MIMIC to use another drive for its use?

        This is running on an NT Server with a drive C and D. Mimic

        has been using drive C:

A. You can set the environment variable MIMIC_PRIV_DIR to point to a location on another drive to do this. Determine 

what directory is being used currently by MIMIC for storing your private data. Copy this over to a different drive and then 

point MIMIC_PRIV_DIR to this location. Restart MIMIC fresh and all subsequent data should be stored on the new drive. 

First, terminate MIMIC Virtual Lab (use File -> Exit). 

●     On Windows NT, use the System Control Panel to set MIMIC_PRIV_DIR to the new path. 

Q. Will there be a port conflict if I install the MIMIC software on a machine with HPOV Network Node Manager 5.01 
installed? 

A. MIMIC should allow you to do what you want. The snag is that HP/Openview requires an SNMP agent to run on the 

management station. This agent conflicts with agent instances running on MIMIC. You have 2 choices: 

a) run MIMIC on one machine, HP/Openview on another. This would require 2 laptops to do your demos. We have found 

this to be a better solution than b), because HP/Openview and other management applications put a lot of burden on the 

machine (memory, CPU utilization). 

b) run MIMIC and HP/Openview on same machine, but this only works if you use non-standard port numbers for the MIMIC 

SNMP agent instances. You will have to configure HP/Openview to probe these non-standard ports. 

Q. Why does HPOV Network Node Manager not discover the MIMIC agents? 

A. HPOV does not discover foreign networks automatically. I quote from the NNM Runtime manual, section "Maps" --> 

"Customizing you Network Map View" --> "Expanding Your IP Network Map" --> "Adding a Network": 

 >For security purposes, Network Node Manager does not discover networks

 >in your internet, beyond your local gateways. You can add an object for

 >an network that NNM has not discovered to an Internet submap, by placing

 >a network symbol on that submap. If you are adding an object for an IP

 >network, NNM will eventually discover it. For network objects that NNM

 >cannot discover, the network symbol remains on the user plane.

For example, if you want to discover the 192.9.201.0 network, you'll have to create a "IP Network" object in the "Internet" 

map. 



Q. Can you run MIMIC and a Web Server on the same machine? 

> Do you see any issues or know of things to watch out if

> we  want to

>   o Run Both MIMIC and Apache web server on a linux machine

>   o Run both MIMIC and IIS web server on an NT machine?

A. MIMIC does not care what other servers run on your system, as long as they are not making use of the same ports as 

MIMIC (eg. UDP SNMP port 161). Since standard web servers use UDP ports 80 or 8080, there is minimal likelihood of a 

clash. 

Q. How do I apply new license keys to the installed software? 

A. If you want to apply new license keys to an already installed version of MIMIC (eg. if you want to change the evaluation 

keys to permanent keys, or upgrade in size), all you have to do is edit the license key files in config/*.lic . There is one file 

per licensed component (Simulator, Compiler, Recorder). Open each file with your favorite text editor, and copy/paste the 

corresponding key. 

Q. Why is my firewall warning me about access to the Internet? 

> Why when I try to telnet my firewall tells me that the prog is trying

> to access the internet?

A. When you use the Device->Telnet... menu item, MIMIC Virtual Lab just invokes the native Telnet application of the 

OS that MIMIC is running on. Just like in the real world, the Telnet is connecting to the IP address of the simulated device, 

and likely it is trying to do DNS name resolution on that IP address. 

Another reason for Internet access is the Update Wizard trying to download updates for your software. The Update Wizard 

runs in a program called wish, which will be reported in the firewall popup. If you allow access to our download site, you 

will be able to install updates and optional software. 

Simulator 
Q. I cannot start agents in MIMIC. I get errors in the log window when starting an agent instance. Why? 

A. This problem is likely caused by the existence of another SNMP agent running on this system. The solution is explained 

in detail in Appendix C, for Solaris or Windows NT. 



Q. I have started agents in MIMIC, but I cannot ping them from my management station. Why? 

A. When you start agent instances with IP addresses on a subnet different from the one that your management station is 

on, you need to tell the management station how to get to the subnet. 

This can be done in most operating systems via a static route with the route command. Assuming that your agent 

instances are on the 192.9.200.0 subnet and that the address of your management station machine is IPADDR, here are 

the route commands for some common operating systems: 

●     Windows NT 

From the DOS command prompt: 

C> route add 192.9.200.0 mask 255.255.255.0 IPADDR 

●     Solaris 2.6, 7 

From any shell as root: 

To add a route:

# route add -net 192.9.200.0 IPADDR 0 

To delete a route: 

# route delete -net 192.9.200.0 IPADDR 

●     Solaris 2.5 

From any shell as root: 

# route add 192.9.200.0 IPADDR 0 

●     Red Hat Linux 5.x 

From any shell as root: 

# route add -net 192.9.200.0 gw IPADDR 

●     Red Hat Linux 6.x 

From any shell as root: 

To add a route:

# route add -net 192.9.200.0 netmask 255.255.255.0 INTERFACE 

To delete a route: 

# route del -net 192.9.200.0 netmask 255.255.255.0 

●     HP/UX 

From any shell as root: 

# route add 192.9.200.0 IPADDR 0 

Q. When I run a simulation, I see some diagnostic messages in the log window. What do they mean? 

A. MIMIC does extensive error logging to justify its actions. If something is not going the way you want it, you can find out 

why from the error log. The error log is normally displayed in a log window with the Lab->Troubleshoot menu item, as well 

as dumped into a file mimiclog.date.time in your temporary directory (/tmp in Unix, \TMP in Windows). 

The most common error messages are described in Appendix C of the online documentation. 



Q. I am seeing the message "buffer full from ADDRESS to ADDRESS" in the error log. What does it mean? 

A. The details for this error message are described in Appendix C of the online documentation. 

Q. How do I change the look and feel of the user interface? 

A. The MIMIC Virtual Lab Java-based user interface is highly configurable as documented by the Sun Java documentation. 

By default, the user interface runs with the Java Metal look and feel. The easiest way to change the look and feel is to 

specify it in the batch file which starts the application, eg. on Windows to get the Windows interface look and feel 

(including inheriting its properties as set in the Display Properties dialog) in vlab*.bat, use the additional 

-Dswing.defaultlaf=com.sun.java.swing.plaf.windows.WindowsLookAndFeel 

on the java invocation. 

 

http://java.sun.com/docs/books/tutorial/uiswing/misc/plaf.html
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